Gå til innhold


Bilde
- - - - -

Ubuntu 12.04 endrer ikke tastaturspråk

ubuntu linux tastatur språk

  • Vennligst logg inn for å svare.
9 svar til dette emnet

#1 Zophram

Zophram

    Nyansatt

  • Pip
  • 4 Innlegg:
  • System: Windows 7, OSX og Ubuntu

Skrevet 03 May 2012 - 09:43

Hei,

Jeg har akkurat installert Ubuntu 12.04 på maskinen min. Jeg har satt språket til norsk under tastaturinnstillinger, men det kommer fortsatt bare tegn når jeg skriver for eks. æ og ø.

Har prøvd meg litt frem med forskjellige typer av de norske tastaturene (eliminate dead keys, osv.) men ingenting av dette ser ut til å hjelpe.

Noen forslag?
Jeg bruker forresten et Logitech wireless illuminated keyboard.
  • 0

#2 Del

Del

    Junior

  • PipPip
  • 441 Innlegg:
  • System: linux

Skrevet 03 May 2012 - 20:01

Hm, ser ut til at dette er en bug som ser ut til å ramme en del. Får håpe den fikses snart. Prøv følgende fix fra terminal:
sudo setxkbmap no
dessverre må denne gjentas ved hver boot, eventuelt kan du legge det inn i en konfigurasjonsfil.

Kom til å tenke på.. Det ser ut til at de som har problemer har satt opp mer enn et språk på tastaturet, og så får de ikke til å bytte mellom. Har du forsøkt å fjerne engelsk layout, slik at du bare har satt opp norsk?

Dette innlegget er endret av Del: 03 May 2012 - 20:05

  • 0

#3 Zophram

Zophram

    Nyansatt

  • Trådstarter
  • Pip
  • 4 Innlegg:
  • System: Windows 7, OSX og Ubuntu

Skrevet 04 May 2012 - 13:09

Ja, jeg hadde i utgangspunktet kun norsk. Prøvde å legge inn slik at jeg hadde flere forskjellige jeg kunne bytte mellom, men det virker ikke som om det reageres på at jeg endrer tastaturtype. Selv om jeg velger for eks. norsk mac-tastatur, så blir det engelske tegn når jeg skriver.

Når jeg trykker på "vis layout" så viser den et norsk tastatur med for eks. æ og ø, men med en gang jeg skal skrive noe blir det bare engelsk.
  • 0

#4 Del

Del

    Junior

  • PipPip
  • 441 Innlegg:
  • System: linux

Skrevet 04 May 2012 - 14:36

Funket kommandoen jeg ga?
  • 0

#5 Zophram

Zophram

    Nyansatt

  • Trådstarter
  • Pip
  • 4 Innlegg:
  • System: Windows 7, OSX og Ubuntu

Skrevet 05 May 2012 - 11:49

Jepp den funket!
Så det må jeg gjøre hver gang jeg logger på?
  • 0

#6 Del

Del

    Junior

  • PipPip
  • 441 Innlegg:
  • System: linux

Skrevet 06 May 2012 - 21:45

Ja, det må du nok med minde du gjør systemendringer. Det ryddigste er å lage en /etc/X11/xorg.conf fil hvor du legger inn hvilket tastaturspråk du skal bruke.

Forhåpentligvis vil Ubuntu fikse problemet slik at du får det fikset i en oppdatering. Hvis du selv ønsker å påskynde prosessen kan du se om du finner bug-rapport på problemet, eller legge inn en rapport dersom du ikke finner en som passer.
  • 0

#7 zandy

zandy

    Junior

  • PipPip
  • 326 Innlegg:

Skrevet 27 May 2012 - 12:15

Jeg hadde samme problemet og ventet noen uker, men de fikser ikke problemet, derfor fjernet den.
Den er litt tregt også i forhold til win7.
  • 0

#8 Del

Del

    Junior

  • PipPip
  • 441 Innlegg:
  • System: linux

Skrevet 28 May 2012 - 10:41

Vet ikke helt hvorfor du testet ubuntu, men du trenger ikke bytte OS for å unngå den buggen. Personlig har jeg aldri brukt Unity, som er desktopmiljøet som er rammet av feilen. Jeg foretrekker KDE, og den kan du installere med pakken kubuntu-desktop (så må du velge KDE ved innloggingsvinduet for å prøve det etterpå). Du har ikke prøvd GNU/Linux før du har prøvd KDE. Win7 er ikke kjappere, men i noen tilfeller vil enkelte oppgaver i Win7 være kjappere av forskjellige årsaker.
  • 0

#9 Trazan

Trazan

    Nyansatt

  • Pip
  • 1 Innlegg:

Skrevet 06 June 2012 - 21:09

Jeg kjører KDE og har samme problem, og samme fix virker.
  • 0

#10 Del

Del

    Junior

  • PipPip
  • 441 Innlegg:
  • System: linux

Skrevet 08 June 2012 - 08:43

Hm, jeg kjører 12.04 Kubuntu på tre maskiner, ikke sett snev av problemet. Kan du si noe om oppsettet ditt? Har du vært i system settings og lagt inn norsk layout?
  • 0





Også tagget med en eller flere av disse ordene: ubuntu, linux, tastatur, språk

0 bruker(e) leser dette emnet

0 brukere, 0 gjester, 0 anonyme brukere