Forenkle formel


1 innlegg i emnet

Skrevet

Jeg har et regneark som skal sjekke, hente og legge sammen verdier i 50 andre ark.

Utfordringen er at det er 135 linjer som skal sjekkes 50 ganger. Dette blir mye skriving og uoversiktlige formler. (Ja vet jeg kan skrive en og kopiere nedover)

Den fungerer pr dags dato, men vil gjerne ha den litt enklere utformet.

Kolonne A = ARKNAVN det skal hentes fra (eks "AN"  -  "DS")

Kolonne F= TALLVERDI som skal stemme med verdi på arket (eks "10"  -  "11")

Kolonne E= TEKSTVEDRI det skal søkes etter (eks "hanske sommer"  -  "hanske vinter")

=HVIS(INDIREKTE(A$10&"!C3")=F12;FINN.RAD(E12;INDIREKTE(A$10&"!E$10:G$60");3;USANN);0)+
HVIS(INDIREKTE(A$11&"!C3")=F12;FINN.RAD(E12;INDIREKTE(A$11&"!E$10:G$60");3;USANN);0)+
HVIS(INDIREKTE(A$12&"!C3")=F12;FINN.RAD(E12;INDIREKTE(A$12&"!E$10:G$60");3;USANN);0)+
HVIS(INDIREKTE(A$13&"!C3")=F12;FINN.RAD(E12;INDIREKTE(A$13&"!E$10:G$60");3;USANN);0)+
HVIS(INDIREKTE(A$14&"!C3)=F12;FINN.RAD(E12;INDIREKTE(A$14&"!E$10:G$60");3;USANN);0)+
HVIS(INDIREKTE(A$15&"!C3")=F12;FINN.RAD(E12;INDIREKTE(A$15&"!E$10:G$60");3;USANN);0)+

LINJEN GJENTAS NED TIL SISTE

HVIS(INDIREKTE(A$60&"!C3")=F12;FINN.RAD(E12;INDIREKTE(A$60&"!E$10:G$60");3;USANN);0)

 

Tankegangen min sier noe som dette, (men vet at denne formelen ikke fungerer, eller finns) :

summer(Gjenta.inntil( HVIS(INDIREKTE(A$11+1 &"!C3")=F12;FINN.RAD(E12;INDIREKTE(A$11 +1  &"!E$10:G$60");3;USANN);0) ;50)

OBS : vil helst unngå macroer da det skaper problemer på andre områder.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive