RDP med annen TCP port fungerer ikke lenger i Windows 10?


7 innlegg i emnet

Skrevet (endret)

Hei,

Har brukte annen TCP port for RDP i alle år på en VM som jeg kan nå uten fra. Men nå plutselig kommer jeg ikke inn på maskinen legger. Heller ikke fra lokale maskiner.
Har testet litt, og når jeg prøver å telnet til IP med den porten jeg bruker, så kommer jeg ikke gjennom, men hvis jeg endre til port 3389 igjen, så kommer jeg igjennom med telnet.

Jeg oppdaterte Windows 10 før helga, så lurer litt på om det har med dette å gjøre?
Noen andre som har samme erfaring?

Endret av Sandemann
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Vell telnet og rdp er to forskjellige protokollerer så ikke rat at det ikke fungerer, jeg har ikke sett at rdp har klart å kjøre på andre porter en 3389 og det er derfor det har vanligvis blitt satt opp rdp gateway server i større nettverk

annet alternativ er jo å ha en firewall \ ruter som klarer å rewirte source og destination ports som gjør at når eksterne forbindelser setter destination port til eks: 63389 og ruteren da rewriter dette til den lokale maskinens 3389 port

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Du kan endre i registeret på maskinen du skal inn på til den lytteporten du skal bruke på rdp.

Ettersom du har oppgradert til Windows 10, så har nok den endra seg:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber

Modifisere med desimal.

Mulig du også må fikle litt med ruter og brannmur.

Endret av pijano
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hei,

Jeg har nok vært litt dårlig til å formulere meg her :)
Oppdaterte til Windows 10 for lenge siden, men tok en Windows Update før helga, og da kom blant annet denne inn:
(KB3140768)

Som du skriver Pijano, så er det måten jeg har endret TCP porten. Også der jeg har endret tilbake til 3389 igjen.
Jeg har gjort dette siden Windows XP, og fungerte fint i forrige uke på Windows 10 også :)

Knutazz: Jeg vet at telnet og RDP er forskjellige protokoller, men man kan bruke telnet for å sjekke om en port er oppe
Eks: telnet 192.168.1.1 3389 - så sjekker jeg om TCP port 3389 er åpen på IP 192.168.1.1

Får evt. prøve port trigger muligheten på routeren da, men er bare så snodig at det plutselig sluttet å fungere :S

Kanskje andre også har problemer med dette:) Finner ikke noe på at de har stoppet dette, men er jo ikke umulig heller :)

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Okay jeg er vandt med å bruke nmap eller wire-shark til å scanne for åpne porter og bruker konsekvent ikke telnet siden der går alt igjenom i klartekst

Hvis dette fungerte fint før oppdateringen så kan det hende at noe har skjedd med brannmur innstillingene som blokkerer trafikk på den porten du har brukt tidligere, vanlig vis så har du 2 brannmurer du må tillate dette i, nr 1 er windows sin innebygde på den maskinen du skal inn på og nr 2 er på ruteren som denne maskinen er koblet til Internett på

Du sier også at dette er en Virtuel Maskin, hva er det du bruker til å kjøre den virtuelle maskinen? VMware Workstation, VirtualBox, Citrix XEN, VMware ESXi? og det har ikke vert endret på noen innstillinger her?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Ok, beklager, leste at du oppgraderte, og ikke oppdaterte, som du korrekt skriver og trodde du mente portregistrering direkte i rdp-vinduet.

Har du forsøkt å skru av brannmur for test? 

Har du sjekket at portnummer peker på riktig maskin i ruteren?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Hei, og takk for svarene :)

Jeg kjører VM'en i VMware Player, og den skal være uendret.

Jeg bruker en Telenor router, og jeg fikk den i forrige uke. Men alt fungerte bra etter at jeg satt opp den. Tror ikke det er den som tuller, da jeg heller ikke kommer igjennom på annen port lokal.

Jeg test installerte en nye Windows 10 i VMware Player og fikk samme issues der når jeg endret TCP port for RDP. Nådde ikke gjennom på endret RDP port på telnet, men gikk fint med standard port.
Men slo av windows brannmur så kom jeg igjennom :)

Kjører Norton Internet Security på den VM som jeg sliter med, så da må det være den som har tatt en selvjustis og stoppet den porten jeg bruker, så får undersøke litt mer der da :) Selv om jeg ikke kom igjennom når jeg slå av denne i en test, men da kan det jo hende at Windows Brannmur slo seg på. Så må nok bare teste mer :)

Tusen takk for alle hint og hjelp :)
 

Endret av Sandemann
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive