Åpne port 21 for FTP tilgang


5 innlegg i emnet

Skrevet (endret)

Hei

Jeg prøver å få tilgang til NASen vin via ftp fra utsiden av nettverket mitt. Ftp serveren er satt opp til å bruke port 21.

Det virket som om problemet er at jeg ikke har forwardet port 21 i routeren min. Greit, jeg går inn på routeren min (zyxel p8702N bak canal digital modem) og prøver dette men får feilmeldingen "The TCP port 21 is reserved for Remote MGMT FTP port " Så jeg antar at dette betyr at port 21 er åpen, men at den ikke er "linket videre" til ip adressen som NASen min har?

Jeg prøvde også å endre ftp serveren til å bruke port xxxx, men jeg får da ikke til å logge meg på fra utsiden. jeg finner ftp serveren men får ikke opp mappene. Jeg har ikke mulighet til å åpne noen porter på nettverket utenfor huset mitt.

Noen forslag til løsninger på dette?

Jeg prøvde også å legge NASen min inn som DMZ i routeren min men det heller fungerte ikke.

Mvh Ole Jonny

Endret av olegje
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Du kan selvfølgelig prøve port 20 også.

Har du forøvrig reservert IP-adressen til NAS-en i ruterens DHCP-oppsett?

Det kan være lurt.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Jeg får samme resultat med port 20 som med port xxxx loggen fra filezilla sier følgende:

Status: Connecting to 31.45.x.xxx.xx...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [TLS] ----------
Response: 220-You are user number 1 of 10 allowed.
Response: 220-Local time is now 11:55. Server port: 20.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER xxxx
Response: 331 User xxxx OK. Password required
Command: PASS *************
Response: 230 OK. Current restricted directory is /
Command: SYST
Response: 215 UNIX Type: L8
Command: FEAT
Response: 211-Extensions supported:
Response: EPRT
Response: IDLE
Response: MDTM
Response: SIZE
Response: REST STREAM
Response: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Response: MLSD
Response: TVFS
Response: ESTP
Response: PASV
Response: EPSV
Response: SPSV
Response: ESTA
Response: AUTH TLS
Response: PBSZ
Response: PROT
Response: UTF8
Response: 211 End.
Command: OPTS UTF8 ON
Response: 200 OK, UTF-8 enabled
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PASV
Response: 227 Entering Passive Mode (10,0,0,xxx,xxx,xxx)
Status: Server sent passive reply with unroutable address. Using server address instead.
Command: MLSD
Error: Connection timed out
Error: Failed to retrieve directory listing
Endret av olegje
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Gå tilbake til NAT i ruteren og åpne for portene 50000 - 50100 mot NAS-ens IP-adresse.

Gjør det samme under "Active Mode" i Filezilla:

https://wiki.filezilla-project.org/Network_Configuration

Har du forøvrig sjekka hva du skal ta hensyn til for å åpne for ftp på NAS-en?

Du har ikke noen sære brannmur-innstillinger satt opp der?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Å ha NASen i DMZ burde hvert fall ha løst problemet om det var snakk om port-problematikk i router..

Hvilken NAS og router har du? Mulig NASen har innbygget brannmur hvor du må åpne for FTP e.l.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive