WinXP: Feilmelding: <windows reet>\system32\hal.dll


13 innlegg i emnet

Skrevet

  • Starter jeg datamaskinen (windows xp) får jeg opp en melding om at denne filen mangler: <windows reet>\system32\hal.dll.

    • Jeg har windows-CD. Setter jeg den inn så skjer det ikke noe annet enn at feilmeldingen kommer igjen.

    [*]Dette kommer opp:

    2vakphz.jpg

    8y9xch.jpg

2

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Prøv dette først: Start PC-en i BIOS, det gjør du ved å Klikke Delete-knappen under oppstart.

Sjekk at CD-ROM står som første oppstartsvalg, så harddisken din med operativsystemet på som neste valg.

Hvis noe annet står først, som en USB-disk eller en harddisk som du ikke har OS på, så kan du få den feilmeldingen.

0E5J8.jpg

Hvis det ser korrekt ut der, så prøver vi noe annet:

Når CD-ROM står først, start opp fra CD (klikk en tast når du får beskjed om det).

Når du får beskjed gjennom installasjonsprogrammet, klikk R for å starte recovery console.

Hvis du har passord på administrator-kontoen, må du legge inn det når du får beskjed, hvis ikke Klikk Enter for å komme videre.

drA4Y.jpg

Skriv så inn: bootcfg /rebuild og klikk Enter

Du får da spørsmål: Add installation to boot list? (Yes/No/All).

Klikk Y for å godta valget.

Så får du: Enter Load Identifier:.

Velg da operativsystemet ditt: Windows XP Professional ellerWindows XP Home Edition

Du får videre: Enter OS Load options:.

Skriv: /Fastdetect

Ta ut CD-en og skriv Exit etterfulgt av Enter, la maskinen restarte.

2

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Slik ser min BIOS ut under Boot:

3129u2r.jpg

Setter jeg inn CD-en så får jeg fortsatt den samme feilmeldingen.

1

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Som du ser, du har feil i oppstartsvalget.

Bruk piltast og gå ned til ATAPI CD-ROM, bruk + tegnet til å få den opp til nr 1.

Sørg så for at IDE Hard Drive står som nr 2.

Maskinen kan ikke starte opp fra Legacy Floppy.

Klikk så F10 for å lagre endringer og restart PC.

Endret av pijano
2

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Jeg endret det til dette:

2wqcpq8.jpg

Den eneste forskjellen er at bildet stopper lengre opp her (omtrent 8 sekunder. Dette bildet kommer rett etter ASUS-logoen og rett før feilmeldingen):

kbvrch.jpg

Endret av deiiNos
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Så hvis du starter opp med XP-CD-en, trykker en tast for å starte opp så kommer du ikke til samme feilmelding?

1

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Rett under det siste bildet jeg la ved skal det stå "trykk en tast for å starte XP-CD-en", men det kommer ingenting. (Jeg har prøvd å trykke). Etter omtrent 8 sekunder kommer den samme feilmeldingen.

Endret av deiiNos
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hva slags tastatur har du? USB?

Har du en gammel type liggende (P2/S) prøv dette i stedet: http://no.wikipedia.org/wiki/PS/2

Er CD-en ripete?

Hvis du ikke kommer videre, virker det som om du har maskinvarefeil.

1

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

(Tastaturet har USB). Jeg vasket XP-CD-en og den fungerer nå. PCen reagerte ikke på kodene i recovery console. Derfor formaterte jeg PCen. Feilen lå i oppstartsvalget i BIOS og i at XP-CD-en hadde riper.

Endret av deiiNos
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Ok, det hadde være flere reparasjonskommandoer du kunne prøvd, det kunne vi tatt i rekkefølge, men det er fint at du fikk løst det med reinstall :-).

Kan være en idé å kopiere CD-en hvis den er ripete.

Endret av pijano
2

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Det funket ikke å reformatere.

  • Starter jeg XP-CD-en så kommer jeg hit og trykker ENTER:

    2ps10fp.jpg
    • Jeg trykker ENTER en gang til her:

      smvuza.jpg

      • Jeg får opp denne og velger å formatere (har prøvd både hurtig og vanlig)

      1zqacg3.jpg

      [*]Etter lang venting får jeg denne opp:

      23r475f.jpg

      Hva skal jeg gjøre?

Endret av deiiNos
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Høres egentlig ut som om harddisken din har tatt kveld, desverre. Er ikke helt sikker, så noen andre får bekrefte

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Det kan virke som om harddisken er gåen ja, hvis ikke tilfellet er at den ikke er koblet skikkelig i, eller koblinger til disken ikke er som det skal være.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive