Bygge linuxsystem, Print/server, mediacenter

286 innlegg i emnet

Skrevet

Ok, skjønner.

Jeg ønsker å gjøre SSD til en partisjon /, swap på minnepenn 4GB. Den 500GB disken er jeg ikke helt sikker på hva jeg kommer til å bruke til. Jeg tenkte å ha all lagring av filer som er viktig på server. Så det er nok nok med 60GB SSD til programmer, cache osv.. Så jeg kan forsåvidt ta ut 500GB HDn. Evt. kunne jeg hatt MBR på HD 500GB. Men jeg tror det skal gå greit å få det opp på SSD. Når jeg tenker meg om så er det mulig at når jeg satte opp partisjoner, så jeg ikke at man kunne velge hvor MBR skulle være.

Så,

Formater Devices på følgende vis:

60 GB EXT4, bootflag

4GB Minnepenn Swap

Deretter svarer jeg ja for å installere.

?

Men jeg tar nok dette etter jula, og hvis du er tilgjengelig litt ut i romjula. Så forstyrrer jeg gjerne julefreden din. Hvis ikke så ønsker jeg deg en God Jul og et Godt nytt år. Jeg er veldig takknemmelig for all hjelp.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Da er det greit. Sørg for at SSD ligger først i boot-rekkefølgen i Bios på hovedkortet. Så starter du installasjonen, da vil MBR på SSD skrives over. Enkel måte å sikre dette på er å koble av alle andre disker. Når du kommer til partisjonering velger du manuell, lager en partisjon av hele SSD som du legger / (dvs. rot) på. Å sett opp USB-penn som swap space gjøres greit etterpå, du trenger ikke swap for å ha et fungerende system.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Da har jeg installert Ubuntu igjen. Men det går ikke ann å skrive til MBR på denne OCZ Solid 3 SSD disken, kanskje pga. av at jeg har prøvd mye forskjellig? Så det er vel liten sjans for at jeg skal få igjen en ny på Garanti.

Så etter flere feilfosøk, la jeg inn boot på en ordinær HD som er på maskina.

Husker du den andre HTPCn min AMD X2-4200, der SSD ble borte innimellom? Det var SSDn (Ocz Agility 3), nå får jeg den ikke opp hverker på den eller fusion pcn min. Dustin sendte en returkonvoulutt uten at jeg spurte om det, bra service :-)

OG serveren med CF kortet, hvis jeg tar ut trådløs nettverkskortet PCI Linksys, så låser den seg ikke. Har du en rask løsning for dette, eller skal jeg gi opp kortet å bruke et USB nettverkskort?

Ærlig talt, jeg lurer på om jeg har stor EMS utstråling eller om det blir produsert mye dårlig HW eller om jeg er veldig uheldig. Det har som regel vært et eller annet problem med vær eneste elektronisk dings jeg har kjøpt de senere år.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Da har jeg installert Ubuntu igjen. Men det går ikke ann å skrive til MBR på denne OCZ Solid 3 SSD disken, kanskje pga. av at jeg har prøvd mye forskjellig? Så det er vel liten sjans for at jeg skal få igjen en ny på Garanti.

Så etter flere feilfosøk, la jeg inn boot på en ordinær HD som er på maskina.

Høres veldig rart ut. Kan være Ubuntu legger inn GPT som standard uten at jeg har fått med meg det. Kan ikke tenke meg at du har ødelagt den, her er det sikkert noe annet ute og går. Fant denne på Arch wiki-en, men vil helst se litt mer på det før jeg jager deg ut på enda en partisjonering og re-install. Uansett her var det jeg fant:

Warning: If you plan to use the GPT partitioned SSD as a boot-disk on a BIOS based system (most systems except Apple computers and some very rare motherboard models with Intel chipset) you may have to create, preferably at the disk's beginning, a 1 MiB partition with the partition type as BIOS boot or bios_grub partition (gdisk type code EF02) for booting from the disk using GRUB2. For Syslinux, you do not need to create a separate 1 MiB bios_grub partition, but you need to have separate /boot partition and enable Legacy BIOS Bootable partition attribute for that partition (using gdisk). See GPT for more information.
ref. https://wiki.archlinux.org/index.php/Solid_State_Drives#Using_MBR_-_DEPRECATED_METHOD_-_Using_GPT_is_Recommended

Husker du den andre HTPCn min AMD X2-4200, der SSD ble borte innimellom? Det var SSDn (Ocz Agility 3), nå får jeg den ikke opp hverker på den eller fusion pcn min. Dustin sendte en returkonvoulutt uten at jeg spurte om det, bra service :-)
Flott, jeg har hørt mye skryt av servicen til Dustin.

OG serveren med CF kortet, hvis jeg tar ut trådløs nettverkskortet PCI Linksys, så låser den seg ikke. Har du en rask løsning for dette, eller skal jeg gi opp kortet å bruke et USB nettverkskort?

Jeg antar du er uheldig med driver. Jeg ville tatt en ekstra runde på det, kanskje lagt inn en nyere linux-versjon for å få nyere driver. Hva slags trådløschip var det som satt i den igjen?

Ærlig talt, jeg lurer på om jeg har stor EMS utstråling eller om det blir produsert mye dårlig HW eller om jeg er veldig uheldig. Det har som regel vært et eller annet problem med vær eneste elektronisk dings jeg har kjøpt de senere år.
Tror jeg ikke. Selv ble jeg dritlei av å bygge PC fordi det var så mye feilvare. Ikke at jeg klarer holde meg unna lell, bygde en maskin i kveld..
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Jeg prøvde iallefall to ganger å sette opp kun / på SSD og satte opp på rullgardina under SDA (ssd) som boot device i installasjonsrutinen, prøvde også å velge SDA1 på andre installasjons-forsøk. Den tredje gangen jeg installerte ga jeg opp og prøvde og satte opp rullgardina (boot device) som den ordinære HD. Ssd ble alltid partisjonert som /, så alt av OS filer ligger på SSD. Det som er forskjellen er at bootsekvensen ligger på HD. Så jeg kan ikke skjønne annet enn at det må være på grunn av problemer med å skrive til MBR. Bios hadde i de 2 første forsøkene SSD som førsteboot. Men jeg har hele tiden fått opp en Ubuntu boot device i Bios, det kan vel være på grunn av at gammel ubuntu boot har ligget på ordinær HD hele tiden. Men uansett SSD har ligget som førsteboot, så den skal jo ikke forstyrre.?

Serveren har Lubuntu 11.10, husker ikke chipset i farten, men det er nok ikke noe nytt HW og det er oppført som støttet av UBUNTU 8.04 eller no sånt no.

Det er jo ikke bare pcr det har vært problemer med. Prosjektor 1, defekt fargeskive (ulevelig bråk) etter 4000 timer, 2. regnbue skjær, 3. ok, men har hatt grønnskjær et par ganger. Men ingen av dem har jeg fått til å gå i sovemodus. Bærbare pcr med større eller mindre feil. Harmony remote, plutselig forsvinner virituelle knapper. Billige multistrømforsyninger, plugger knekker lett. 1 av 3 laserskrivere ble defekt etter kort tid. Bestilte masse utstyr fra dealextreme, halvparten fungerte ikke. Men det er jo Kinasøppel da.. De siste 3-4 mobilene jeg har hatt har de jeg har ringt til hatt problemer med å høre meg, faktisk ikke noe stort problem med den siste. Kan være på grunn av at jeg har hatt en del lommerusk da.. Den siste Galaxy S2, lever sitt eget liv, automatisk aktivisering av div. tjenester som bilmodus, høytaler osv. Får ikke orginalt software til å kommunisere med tlf. Vært div. småting ellers med de andre tlf. også. Og selvsagt den berømte Canal Digital dekoderen.

Endret av sitdown
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Jeg prøvde iallefall to ganger å sette opp kun / på SSD og satte opp på rullgardina under SDA (ssd) som boot device i installasjonsrutinen, prøvde også å velge SDA1 på andre installasjons-forsøk. Den tredje gangen jeg installerte ga jeg opp og prøvde og satte opp rullgardina (boot device) som den ordinære HD. Ssd ble alltid partisjonert som /, så alt av OS filer ligger på SSD. Det som er forskjellen er at bootsekvensen ligger på HD. Så jeg kan ikke skjønne annet enn at det må være på grunn av problemer med å skrive til MBR.

Spørs om jeg må lese meg opp litt på GPT. Hadde du kun SSD tilkoblet maskinen da du installerte sist? Isåfall (med mindre GPT kan legge noe i Bios), så er det ikke noe annet valg enn at grub havner på bootsektor til SSD. Kan det vøre at du har satt grub til å bli installert på partisjonen istedet for på disken? Isåfall får vi installere grub på nytt. Endret av Del
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Det var en vanlig hd koblet til, og det er den jeg måtte installere grub på for å få det til.

Nei, det har kun vært en partisjon på SSD under de tre forsøkene. Kun root.

Men det går jo greit å ha grub på MBRn på ordinær HD? Skal uansett være på maskina.

Oppdattering på server: Den har låst seg uten at nettverkskort sto i, tok bare litt lenger tid.

Kunne du gitt meg tips til hvordan man kunne starte opp maskina, rett i terminal uten at login manager starter opp. Da får jeg ekskludert at det har noe med login manager eller LXDE.

Endret av sitdown
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hm, har du forsøkt å installere med kun SSD tilkoblet slik jeg foreslo?

Kan du minne meg på hardware på server? Sannsynligvis har du en driver som ikke oppfører seg. Enkleste måten å få til testen du ønsker, er å stoppe lxsession etter boot. Det kan eksempelvis gjøres via ssh.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Nei, har ikke prøvd det og tviler sterkt på at det vil hjelpe. Og jeg begynner å bli lei av å installere gang på gang og det gjør vel også SSDn. ;-) Hva er det du tenker kan hjelpe med det, at jeg ikke har satt riktig i BIos?

Om jeg lar LXsession starte opp og deretter deaktiviserer, vil jeg da ekskludere alt som har blitt startet av X shellet?

Jeg tar en liten pause fra pc greiene, men skal opppdattere deg så fort som jeg får igjen lysten.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Jeg ba deg om å koble av alle andre disker sist du installerte:

http://itpro.no/supportforum/index.php?showtopic=78310&view=findpost&p=609041

Hvis det er tull med bios på hovedkortet, er det rimelig bombesikker metode (med mindre du manuelt setter at grub ikke skal installeres der, men på en partisjon). Da er det kun en bootsektor som kan skrives over. Jeg ville i grunnen bare vite om du gjorde det jeg foreslo.

Jeg vet ikke hva som er skjedd, men jeg har liten tro på at bootsektor på disken er defekt. Skjønner at du blir lei av å installere, la oss fikse det uten det. Vet du hvilken disk ssd er? Hvis det er /dev/sda, så gjør du følgende etter å ha bootet (hvis du ikke får til å boote, får du da grub prompt?):

sudo update-grub

sudo grub-install /dev/sda

Hvis du stopper xserver vil vel alle grafiske apps stenges ned ja.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Fusion Mediacenter: Kjørt kommandoen du foreslo, fortsatt GPT partisjon.. Jeg har gjorde jo sda (ssd) til root gjennom standard installasjon UBUNTU.

Som sagt fikk jeg jo ikke bootet ved å installere boot på MBR SDA, men måtte legge den til ordinær HD.

Husker ikke om jeg fikk grub rescue, men har fått det opp før flere ganger ved installasjon på en av maskinene mine.

Tror ikke jeg fikk opp det sist gang.

leieboere@leieboere-HTPC:~$ sudo update-grub

[sudo] password for leieboere: 

Generating grub.cfg ...

Found linux image: /boot/vmlinuz-3.0.0-14-generic

Found initrd image: /boot/initrd.img-3.0.0-14-generic

Found linux image: /boot/vmlinuz-3.0.0-12-generic

Found initrd image: /boot/initrd.img-3.0.0-12-generic

Found memtest86+ image: /boot/memtest86+.bin

done

leieboere@leieboere-HTPC:~$ sudo grub-install /dev/sda

/usr/sbin/grub-setup: warn: This GPT partition label has no BIOS Boot Partition; embedding won't be possible!.

/usr/sbin/grub-setup: warn: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..

/usr/sbin/grub-setup: error: will not proceed with blocklists.

leieboere@leieboere-HTPC:~$ 

X2-4200 Amd media center: Fått ny SSD fra Dustin, installerer Linux mint istedet for Vista Premium, lurer på om jeg skal gå bort fra Utuntu-unity ettersom det har blitt mer lagg på Fusion pcn.

Server:skal prøve å installere lubuntu på SSD disk istedetfor CF-card for å se om pcn fortsatt vil henge da.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

OK, da har jeg ihvertfall en teori om hva som har skjedd. Du hadde i en disk på minst 2TB da du installerte (i tillegg til SSD). Partisjoner på over 2TB krever GPT, og derfor har du GPT (med mindre du selv valgte det manuelt under installasjon). Videre har den store disken blitt boot-disken, enten fordi du valgte feil disk under installasjon, eller fordi Bios rapporterer feil diskrekkefølge. Siden du har GPT partisjonering er ikke MBR tilstrekkelig for å huse partisjonstabellen, du må ha en egen partisjon for GPT som gir den ekstra plassen GPT krever, minimum 1MB (MBR er bare 512 byte, og det huser mer enn partisjonstabellen). Denne partisjonen har typebetegnelsen bios_grub. Du finner detaljert gjennomgang på Debian forumet for hvordan du får lagt inn den ekstra partisjonen, og installert grub på ssd. Se her:

http://forums.debian.net/viewtopic.php?f=5&t=60352#p352625

(bare husk at # betyr at du må skrive sudo foran, altså bruk sudo på begge kommandoene)

Angående Fusion, installer AMD-driver gjennom Additional hardware drivers, så skal lagg forsvinne, og siste skudd xbmc (som kom ut i jula) gi deg gpu-aksellerert HD-video.

SSD istedet for CF kan være en god ide. Mange av disse minnekortene og minnekortleserne er rimelig råtne å kjøre OS fra.

Endret av Del
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Siste gang jeg installerte ubuntu var det kun en 500GB HD i tillegg. Men jeg har hatt 2x2TB disker før. Kan det være at det har hengt igjen? Tror jeg slettet og la inn nye partisjoner sist gang.

På X2-4200 pcn installerte jeg linux mint og det går rykende raskt. Eneste negative er at jeg ikke får spolt på Nrk nettv og hvis jeg pauser stopper spilleren når bufferen er tom og må starte klippet fra begynnelsen igjen..

Serveren har gått i natt uten stopp, kjøpte forresten en Kingston 16GB til ca 380kr..

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Siste gang jeg installerte ubuntu var det kun en 500GB HD i tillegg. Men jeg har hatt 2x2TB disker før. Kan det være at det har hengt igjen? Tror jeg slettet og la inn nye partisjoner sist gang.

Det spørs nok om du bare brukte den gamle partisjoneringen. Uansett, oppskriften jeg ga deg over vil installere også en GPT på SSD disken. Det er antagelig ingenting galt med disken. Eventuelt er jeg redd du må partisjonere på nytt om du ønsker å unngå GPT, hvilket dessverre enklest gjøres ved en re-install med kun SSD i maskinen.

På X2-4200 pcn installerte jeg linux mint og det går rykende raskt. Eneste negative er at jeg ikke får spolt på Nrk nettv og hvis jeg pauser stopper spilleren når bufferen er tom og må starte klippet fra begynnelsen igjen..
Hvis du brukere VLC til å se nrk, så kan du hoppe frem og tilbake (men den må bufre igjen for hvert hopp så litt tålmodighet hjelper). Du finner installasjonveiledning her:

http://wiki.diskusjon.no/index.php/Guide:%28K%29Ubuntu_server_howto#NRK_nett-tv

Serveren har gått i natt uten stopp, kjøpte forresten en Kingston 16GB til ca 380kr..

Slik skal det være :)
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Da tenkte jeg å installere ubuntu på nytt på Fusion pcn.

Prøvde meg på backup og har hentet ut mine pakker, men å kopiere etc sliter jeg med.

Prøvde: sudo cp -pr /etc /home/slettes , fikk ingen feilmeldinger i terminalen men ingenting dukket opp i filmanager når jeg så i mappen. Selv om jeg hadde valgt vis skjulte filer.

Så hva gjør jeg feil?

Serveren bare går og går. Så det var et eller annet i forhold til CF-kortet.

Endret av sitdown
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Da tenkte jeg å installere ubuntu på nytt på Fusion pcn.

I det minste går det fort :unsure:

Prøvde meg på backup og har hentet ut mine pakker, men å kopiere etc sliter jeg med.

Prøvde: sudo cp -pr /etc /home/slettes , fikk ingen feilmeldinger i terminalen men ingenting dukket opp i filmanager når jeg så i mappen. Selv om jeg hadde valgt vis skjulte filer.

Det funket fint her, sikker på at det var det du skrev? Forsøk med

sudo ls /home/slettes

Tips: bruk cp .a istedet for cp -rp.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Home hurtigknappen i filbehandleren i Unity er \home\leieboere\, det er derfor jeg ble forvirret. Så etc ligger i slettes mappen på home.

Med -a så er leieboere eier, med -pr så er fortsatt root eier.. Hvis jeg lagrer filen på HD (ssd) så er filen 8,9mb mens på minnepinne er den 8,2mb, hva sier det deg?. Hva er best å gjøre? Hadde jo vært greit å hatt mulighet å kunne flytte filen lett og deretter endret til root etter gjennoppretting.

Når jeg skal installere på nytt så kan jeg gå inn i root og legge inn igjen ny etc mappe skal jeg oppdattere systemet før jeg legger inn mine pakker og etc?

I forhold til Vlc og Nrk, så er det ingen plugin lagd for nyeste firefox versjon, så da må jeg vel vente?

Endret av sitdown
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Mente naturligvis cp -a, da blir vel ikke leieboer eier til noe annet enn hva leieboer var eier til før. Alt skal bevares slik det var.

Istedet for å kopiere tilbake hele /etc, ville jeg nøyd med delene av /etc som du har endret selv. Sannsynligvis er det lite eller ingenting. Mappen /etc opprettes og populeres under installasjon.

Les lenken jeg ga deg en gang til, den forteller deg hvordan du med en ekstra plugin kan overstyre versjonkontrollen slik at du likevel kan bruke mediaplayerconnectivity. VLC og NRK funker fint på nyeste Firefox.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Vlc gikk greit.

Når jeg kopierer etc til minnepinne så ble leieboere eier, når jeg kopierte til home mappe ble root eier. Når jeg flyttet denne med filbehandler til minnepinne endret rettighetene seg til leieboere..

Jeg har installert linux mint på fusion pcn nå, ettersom firefox og filbehandler henger seg innimellom og at det generelt er litt treg responstid. Får se om det blir noe forskjell. Ser bra ut så langt.

Slettet partisjon og la til ny og formatterte SSD uten andre HDr. Nå har jeg MBR.

Jeg kommer til å oppdattere systemet og kan jeg kjøre tilbake pakkene og ETC fra Ubuntu oppsettet eller vil det krasje med linuxmint shellet?

Skal jeg fortsatt bruke nathan ppa:

sudo apt-add-repository ppa:nathan-renniewaldock/xbmc-stable

sudo apt-get update

sudo apt-get install xbmc

Endret av sitdown
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Når jeg kopierer etc til minnepinne så ble leieboere eier, når jeg kopierte til home mappe ble root eier. Når jeg flyttet denne med filbehandler til minnepinne endret rettighetene seg til leieboere..

Den som kopierer blir eier til kopien. Hvis du vil at rot skal bli eier (slik som når du kopierer /etc) så slenger du sudo foran cp.

Jeg har installert linux mint på fusion pcn nå, ettersom firefox og filbehandler henger seg innimellom og at det generelt er litt treg responstid. Får se om det blir noe forskjell. Ser bra ut så langt.
Burde gli greit så lenge du har bra med minne. Vi kan jo se nærmere på det hvis problemet vedvarer.

Slettet partisjon og la til ny og formatterte SSD uten andre HDr. Nå har jeg MBR.
Supert, da er den ute av verden, og diskene dine virker som de skal.

Jeg kommer til å oppdattere systemet og kan jeg kjøre tilbake pakkene og ETC fra Ubuntu oppsettet eller vil det krasje med linuxmint shellet?
Ikke kjør tilbake hele /etc, det er som å be om juling uansett system. Legg tilbake de filene i /etc som du har brukt tid på å sette opp hver for seg, det er kanskje ingen filer. Så kopi av /etc er mer sånn just-in-case, eventuelt hvis du vil ha alt helt identisk med forrige install (men det er ikke identisk lengre uansett).

Skal jeg fortsatt bruke nathan ppa:
Nei, det har skjedd en vesentlig endring siden sist. Din prosessor har fått grafikk-aksellerert video, slik at du kan kjøre full HD uten å stresse CPU med xbmc. Støtten dekker formatene H264 og VC-1. Les mer her:

http://www.phoronix.com/scan.php?page=news_item&px=MTAyODU

så bruk utviklerens ppa, da blir det slik:

sudo apt-add-repository ppa:wsnipex/xbmc-xvba

sudo apt-get update

sudo apt-get install xbmc

sjekk også at Mint har Catalyst/fglrx driveren fra AMD installert.

Endret av Del
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Har brukt sudo foran, men logget inn i root og prøvde både med og uten. Ikke noe forskjell. Når jeg legger filene inn på minnepenn blir det leieboere som er eier og ikke root.

Hvis jeg ikke kan legge inne etc så er jo backup på denne måten av liten nytte. Jeg har lyst til å slippe å konfigurere systemet og programmene slik jeg ønsker det hver gang jeg velger å installere på nytt pga. feil på systemet eller at det har gått en tid.

Da virker det som om at jeg burde ta en full backup.

Jeg installerte Mint pga. at det gikk tregt på Ubuntu, selv med propiotære drivere på grafikken. Burde ha spesifisert at det gjaldt Ubuntu. Bruker mye mindre CPU enn Ubuntu. Spesielt ettersom det i cpu prosessen (system monitor) noen ganger går over 100% i Mint, tyder på at total prosessorbruk vises som 2x100% på grunn av 2 cpu'r. Så når det står at Firefox bruker 20% bruker den i realiteten 10% av total CPU.

Takk, da fortsetter jeg i morgen :-)

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Har brukt sudo foran, men logget inn i root og prøvde både med og uten. Ikke noe forskjell. Når jeg legger filene inn på minnepenn blir det leieboere som er eier og ikke root.

Ah, minnepennen bruker FAT filsystem, det støtter ikke eierskap i det hele. Alt der blir autmoatisk vist med den som monterte pennen sitt eierskap, men det betyr ingenting, rettigheter og eierskap er nemlig ikke støttet i FAT. Les mer her:

http://www.linuxquestions.org/questions/linux-newbie-8/howto-permissions-and-ownership-on-fat-and-ntfs-filesystems-710228/

Jeg har lyst til å slippe å konfigurere systemet og programmene slik jeg ønsker det hver gang jeg velger å installere på nytt pga. feil på systemet eller at det har gått en tid.
Her er poenget. Hvis du tar full backup vil du bare rulle tilbake det samme systemet, som har samme feil. Det er kun når du vil ha alt identisk med slik det var at det å rulle tilbake hele /etc har noe for seg. Eksempelvis ved harddiskhavari. En mye hyppigere årsak er at du ønsker å sette opp systemet litt annerledes, innstalere på nytt, installere på en annen maskin, eller rette opp systemet etter at det har blitt fucket opp. I disse tilfellene er ofte /etc en del av problemet.

Alt ditt personlige oppsett er uansett i hjemme-mappen. Mappen /etc har system-wide settings. Svært lite skal trenge å endres i /etc. I ditt tilfelle er endringene i /etc antagelig begrenset til /etc/fstab (her var partisjoner og GPT satt opp, ikke noe du ville ta med deg inn i ny installasjon altså) og /etc/apt/sources.list.d (hvor ppa til xbmc var satt opp, heller ikke noe du vil ha med deg). Med trøblete hardware hender det man må gjøre litt fikling i /etc, da vil man typisk ha det med seg ved neste installasjon, men da vet man også hvilke filer det gjelder.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Ah, selvsagt. Da blir rettighetene til den mappen jeg legger tilbake etc i som bestemmer rettighetene når jeg legger det inn på ny installasjon.

Ved full backup så har jeg satt opp f.eks. lynmeld, skype, xbmc osv. i mint 12. Om systemet blir uhåndterlig så kan jeg gjenooprette systemet og kjøre update og upgrade til jeg kommer tilbake til mint 14. Dette burde vel fungere greit?

Så du mener at jeg med å kopiere ut homemappen og minepakker så vil jeg få gjennopprettet mesteparten av mitt config i f.eks. fremtidig linux mint 14?

Systemet mitt er oppdattert og jeg lastet inn propiotær grafikkdriver, men tekst i menysystem og desktop ble korrupt, ikke ikoner og i programmene. Vil det være stor forskjell i forhold til å kjøre linux drivere på det integrerte grafikkortet?

Burde jeg eventuelt vente med å installere Xbmc om jeg skal aktivisere propiotære drivere?

Hvordan legger jeg til programikoner på desktop og i hurtistart linja?

For video samtaler burde jeg installere empathy?

Endret av sitdown
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Ved full backup så har jeg satt opp f.eks. lynmeld, skype, xbmc osv. i mint 12. Om systemet blir uhåndterlig så kan jeg gjenooprette systemet og kjøre update og upgrade til jeg kommer tilbake til mint 14. Dette burde vel fungere greit?

Skjønner ikke helt hva du mener her, men kan legge til at installasjoner utover pakkesystemet gjerne må gjøres på nytt. Lymeldingsklienter er det nok av i pakkesystemet. Oppskrift for xbmc og skype er bare å ha i en tekstfil, så er det klipp og lim til terminalen et par sekunder.

Så du mener at jeg med å kopiere ut homemappen og minepakker så vil jeg få gjennopprettet mesteparten av mitt config i f.eks. fremtidig linux mint 14?
Nettopp, og har du satt opp noe knot som ligger i /etc, så er det antagelig ikke verre enn å kopiere over en eller to filer derfra i tillegg.

Systemet mitt er oppdattert og jeg lastet inn propiotær grafikkdriver, men tekst i menysystem og desktop ble korrupt, ikke ikoner og i programmene.
Hæh? Slikt bruker ikke å skje. Har du tatt en re-boot? Hvis det er så ille etter en re-boot, og med oppdatert pakkesystem (sjekk med å kjøre sudo apt-get update og sudo apt-get upgrade), så har noe knekt systemet ditt.

Vil det være stor forskjell i forhold til å kjøre linux drivere på det integrerte grafikkortet?
Fortsatt en del bedre ytelse, og bedre støtte for nyere opengl. På den negative siden støttes ikke KMS, så du vil ikke få like smooth oppstart.

Burde jeg eventuelt vente med å installere Xbmc om jeg skal aktivisere propiotære drivere?
Aktiver gjerne driveren først, i tilfelle xbmc kjører systemsjekk etter den. Du legger tross alt inn en utviklerversjon av xbmc, så kan hende den er kilen på slikt.

Hvordan legger jeg til programikoner på desktop og i hurtistart linja?
Høyreklikk der hvor du vil ha det, resten er ganske selvforklarende.

For video samtaler burde jeg installere empathy?
Jeg bruker ikke videosamtaler, så jeg er antagelig ikke den rette til å svare. Endret av Del
1

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Å ta en image av Ssd etter at jeg har satt opp alt jeg ønsker å ha systemet. Når maskina krasjer ved oppdattering til Mint 13 om 1 år så kan jeg bare kjøre tilbake Mint 12 og prøve på nytt. F.eks.

Jeg har gjort alt det du sa og fortsatt problemer. Når jeg deaktiviserer driveren er alt ok igjen. Har sett andre som har hatt det samme problemet før. Det gikk greit i Ubuntu, men ikke på Linux Mint.

Høyreklikk på skrivebordet, hurtiglinje eller program i meny fungerer ikke. Dette gjelder begge pc'ne mine med mint.

I Ubuntu bare dro jeg bare programikonene inn i unity sidebaren.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive