Hente info fra to excelark og skrive til tom celle

13 innlegg i emnet

Skrevet

Hei.

Jeg lurer på om det er mulig å sammenligne informasjon i to exceldokumenter basert på likheter.

Eks:

Ark 1.

Tekst1|Tekst2|Tom celle

Ark 2.

Tekst1|Tekst2

Jeg ønsker å hente ut Tekst2 i Ark 2 hvis Tekst1 i begge ark er like.

Jeg ønsker dermed at verdien Tekst2 i Ark 2 skrives i Ark 1 Tom celle.

Litt knotete forklart, men håper på svar allikevel.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

En formel:

=HVIS(Ark1!A1=Ark2!A1;Ark2!B1;"")

De to dobbeltsnuttene gjør at den tomme cella forblir tom dersom innholdet ikke er helt likt.

Endret av Geir_HK
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hei. Og takk for svar. Får ikke testet dette før i morgen.

Vet du om dette også fungerer på områder?

A2:A90 f.eks?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Ja det skal fungere.

Du gjør som følger: Marker den cella der du skrev inn den første formelen. Jeg forutsetter C1 i dette tilfellet.

Legg merke til + tegnet i det ene nedre hjørnet i den cella du har markert. Dette hjørnet kan du "dra" nedover til cellene under. Da vil formelen fylles inn i cellene du drar over. I tillegg oppdateres celle-referansene slik at i cella under så får du:

=HVIS(Ark1!A2=Ark2!A2;Ark2!B2;"")

Nb: har rette opp en skriveleif i formelen min i forrige innlegg :blush:

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Testet det nå, og får enten usann eller #verdi.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Bør kanskje legge til at det er 1313 linjer i ark1 og 9757 linjer i ark to.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Bare en lite sidenotis; Husk at formelen blir anderledes dersom du f.eks har en engelsk versjon av Excel..

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Har norsk Office

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Start med den enkle formelen - =HVIS(Ark1!A1=Ark2!A1;Ark2!B1;"") - altså hvor du bare sammenligner 2 celler (ikke 2 områder). Hvis en av cellene du skal sammenligne er på samme ark som formelen kan du droppe Ark.

Eksempel:

Hvis formel-cellen er C1 på Ark2

=HVIS(Ark1!A1=Ark2!A1;Ark2!B1;"") - dropp det som er gjennomstreket. Du trenger ikke å henvise til Ark hvis det er på samme arket som formelen.

Fylle ut hele med Autofyll i kolonne nedover:

=HVIS(Ark1!A1=Ark2!A1;Ark2!B1;"")

=HVIS(Ark1!A2=Ark2!A2;Ark2!B2;"") Skrive inn 2 av formlene. "Dra" formelen nedover med Autofyll (en spesiell cursor som dukker opp rett utenfor nedre høyre hjørne av cellen).

Hvis du får USANN:

Har du glemt "" i siste del av formelen? Dette angir at cellen skal være tom hvis sammenligningen er usann.

----------

Hvilken oppgave er det du egentlig prøver å løse?

Bør kanskje legge til at det er 1313 linjer i ark1 og 9757 linjer i ark to.

Svarene du har fått forutsetter stort sett at begge arkene er omtrent helt like.

Formelen tester om 1 bestemt celle på Ark1 stemmer med 1 bestemt celle på Ark2.

Den tester ikke om en av cellene på Ark1 stemmer med 1 bestemt celle på Ark2, altså om celler i et område stemmer med cellen.

Endret av Morten58
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hei Morten.

Jeg har en to lister over serienummer.

Den ene listen inneholder bare serienummer, og den andre inneholder serienummer og datamaskinnavn.

Jeg ønsker å sammenligne de to listene og hente maskinnavnet fra listen som inneholder det og knytte det opp mot serienummer i den første listen

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Da ble oppgaven mer forståelig, men da ble den også utenfor området jeg har peiling på. Jeg bruker stort sett bare basisfunksjoner i regneark.

FINN.RAD() eller noe sånt noe finner frem til matchende nummer i en tabell. Altså at man sjekker om verdier i et område matcher verdien i en celle. Her bør du egentlig få svar fra noen som har erfaring med dette. Jeg har ikke engang Excel installert på denne maskinen jeg skriver fra.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Takk for svar Morten :)

Da håper jeg noen kan hjelpe meg med dette, så lærer vi noe begge to :blush:

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

A - B - C - D

6 - - 1 - PC1

4 - - 2 - PC2

2 - - 3 - PC3

1 - - 4 - PC4

5 - - 5 - PC5

3 - - 6 - PC6

7 - - 7 - PC7

For å finne tekst i rad D og legge den i rad B ut fra verdi i rad A lik verdi i rad C kan du bruke følgende formel:

=FINN.RAD(A1;$C$1:$D$7;2;USANN)

NB! Husk at kolonne C må sorteres fra minst til størst først.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive