Problemer med Charset i script

4 innlegg i emnet

Skrevet

Hei,

Jobber med installasjon og oppsett av et system kalt WorkorderTS

www.workorderts.com/

Problemet er at når jeg skal skrive en beskrivelse på en sak, og bruker tegnene Æ, Ø eller Å blir tegnene helt merkelige etter at jeg har lagret saken...

Sjekket i kildekoden, og den bruker Latin1, det samme gjør MySQL-databasen.

Noen som har en anelse om hva det kan være?

Setter stor pris på all hjelp! :)

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

UTF-8 eller iso-8859-1 er vel korrekt charset å bruke.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Det er iso-8859-1 den bruker. Også fant jeg ut at den ikke støttet UTF-8..

Skjønner virkelig ikke hvorfor æ, ø og å blir feil.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

For det første må charset du lagrer filen i samsvare med det som du oppgir i http headeren som blir sendt til brukeren, og så må det være samme i html headeren. henter du info fra en database må php vite hvilken charset du har i databasen også. Bruk UTF-8

Endret av feskehau
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive