[LØST] Hjelp med Terminal pålogging fra vista

16 innlegg i emnet

Skrevet

Bedriften har kjøpt inn nye pc'er som kjører vista business. Noen av de skal være i et sikkert nettverk, som kun tillater internett og mail gjennom terminalserver. Problemet er at vista pc'ene ikke får koblet til terminalserveren fra det sikre nettverket. Fra det usikre nettverket fungerer det uten problemer. Vi har prøvd både gammel og ny rdp klient. Terminalserveren er i det usikre nettverket, mens problemet er med vista pc'er fra sikkert nettverk som skal koble til ts i usikkert nettverk. maskiner med xp klarer dette uten problemer.

Noen som har noen råd?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Du kan jo gjerne begynne med å beskrive litt bedre.

Får ikke koblet til? Hva skjer da? feilmelding med en gang? Eller ser det ut til at den kobler seg opp men går i time-out og så en eller annen feilmelding?

Har du sjekket firewall logger? Og hvilken terminal server er det vi snakker om? WIn200, 2003? 2008? R2? SP?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

På Vista klienten står det bare "denne datamaskinen kan ikke koble til den eksterne datamaskinen. Prøv å koble til på nytt. Kontakt eieren av datamaskinen eller nettverksansvarlig hvis problemet vedvarer"

Når jeg bruker en XP rdp klient kommer denne feilmeldingen: "klienten kan ikke koble til den eksterne klienten. Det kan hende at eksterne tilkoblinger ikke er aktivert eller at datamaskinen er for opptatt til å godta nye tilkoblinger. det er også mulig at nettverksproblemer forhindrer tilkobling. prøv å koble til på nytt senere. hvis problemet vedvarer, kontakter du systemansvarlig"

Terminal serveren kjører windows 2003 server R2.

De andre terminal serverne kobler seg til med en gang, men ikke serveren som brukes til internett og mail.

Kan det være at det blir problemer når man kobler på tvers av nettverk?

Kan det være noen sikkerhetsinnstillinger i vista business?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Har du sjekket at rdp trafikk slippes inn fra klientene i firewall??

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

alle klienter som kjører xp klarer å komme inn helt fint med remote access, men ikke de nye pc'ene som kjører vista business

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hei. Nettverk er ikke mitt sterkeste felt. Men er jo borti litt av hvert.

Er det du snakker om en VPN tilkobling?

Vet av erfaring at VISTA er problematisk mot CISCO p.g.a. brannmuroppsett.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

det er ikke en vpn. Tilkoblingen skjer fra nettverket på arbeidsplassen. Vi har funnet ut at det muligens er brannmur innstillingene som sperrer, for det funker å koble seg opp mot andre terminalservere i det sikre nettverket. problemet er når vi skal kjøre en terminalpålogging gjennom brannmur til det usikre nettverket, for å komme til internett og mail. Når vi koblet om så nettverket var i den usikre sonen, funket det helt fint. Derfor tror vi det er brannmuren som feilen ligger på.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hvis du har kontroll på brannmuren, burde det jo være enkelt å finne ut hva som kreves da.

I en rolig stund, åpne alt og sett på logging, start RDP og av igjen, lukke igjen, lese logger og se hva du får ut av det.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Da foreslår jeg å tråle gjennom brannmurloggene. I 75% av tilfellene ligger der en oppføring på det som er problemet. 

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Jeg foreslår følgende:

cmd (dos) som administrator. skriv så inn følgende og trykk på enter og restart maskine

netsh interface tcp set global rss=disabled autotuninglevel=disabled

Denne linjen gjør underverker på Vista maskiner i ett nettverk. 90% av alle som har problemer med tregheter eller andre rare ting i nettverket som websider som ikke åpner seg osv på sine vistamaskiner løser dette ved å taste inn ovenstående linje. Det finnes tilsvarende problemer i Windows 7 også.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Kan du bruke telnet inn til port 3389 på server? får du koblet til?

bruk denne formen fra en cmd-prompt: telnet "serverip" 3389

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Han har XP maskiner i samme nettverk som klarer å koble til og derfor trenger han ikke å teste mot noen som helst port. Løsnignen er som jeg sa. Har løst hundrevis av nettverksproblemer ute hos kunder hvor andre har satt opp Vista og ikke kjørt den kommandoen. Vista har fått ett veldig ufortjent rykte nettopp pga. at folk ikke skjønner hvordan det skal settes opp. Windows 7 vil også kunne få ett slikt rykte pga. problemene mange har med å kjøre Messenger når de er i ett nettverk, dette løses på tilsvarende måte. 

 

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

RDP = Remote Desktop Protokol (tilkobling til eksternt skrivebord). Før het det Terminal Services Client, og skriver du mstsc i Start / kjør dukker innloggingsvinduet opp.

Jeg ville også prøvd forslaget til Danne, ettersom det fungerer ellers i nettverket, men en kan aldri GARANTERE, som Danne skriver, at èn løsning gjelder for samme problem.

Det er ALDRI 100 % garanti for noe som helst...men sannsynligvis kan dette være løsningen her.

 

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Nå foreslår jeg at resterende poster i denne tråden omhandler trådstarter og det som trengs for å løse hans problem!

Jeg har også moderert tråden litt, og klipt bort alt som ikke omhandler trådstarter sitt problem.

Og hakke ned på andre og kjempe om hvem som er best i det ene og det andre er ingen god løsning  :)

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Takk!

Som noen kanskje har fått med seg, fungerer det fra Vista i det usikre nettverket, altså på samme nettverk uten brannmur.

Altså kan vi utelukke autotuning funksjonen i Vista, den vil bare gjøre at det går kjepetreigt men du får logget deg på.

Så det som er interresant her, er jo om trådstarter har har identifisert hva loggen til brannmur sier. Har selv brukt Vista mellom brannmur og åpne kun tcp 3389 og har aldri hatt problemer med dette, så at det skyldes brannmurregler eller noe annet i den er jo nærliggende å tro.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Problemet er nå løst. Det viste seg at det var brannmuren som gjorde det. Et eller annet med at source portene måtte utvides, da vista brukte flere tjenester/protokoller/prossesser på rdp. Så når en kar utvida området (range) på portene, så funka det fint. Takk for hjelpen

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive