[LØST] Windows home server og port problemer.

8 innlegg i emnet

Skrevet (endret)

Hei

Jeg sendet denne mailen til min internett leverandør: Agder Breiband.

Jeg har problemer med å få kontakt på min Windows home server fra internett.

Portene som må være åpen er: port 80, port 443 og port 4125 Jeg har Åpnet disse portene i routeren, men nei.

Jeg har koblet direkte i modemet, men NEI.

Trur problemet ligger i modemet, eller selve nette.

Hva skal jeg gjøre, kan dere hjelpe meg med dette?

Svaret fra de: Hei

Alle porte på WHS må være over 1024 pga brannmuren til agderbreiband er stengt på alle porter opp til 1024.

Ellers må du ta kontakt med enten Windows norge eller IA- Data i Åmli og se om dei kan hjelpe deg med og sette den opp.

MVH

Joachim Agder Breiband

Så spørsmålet, hva gjør jeg nå? Kan jeg skifte porter, bruke noen andre porter? Er det noen der ute som kan hjelpe meg?

Mvh Svein Mortensen

Fant dette på nette: You would need to change the settings in which IIS (the web server program on your WHS) listens for incoming web requests. Currently 80 & 443. You will need to go in to Start, Programs, Administrative Tools (on your WHS) and Internet Information Services (IIS) Manager.Right click on Default Website and choose properties. Change the ports to some that are not in use and that your ISP does not block. YOu will need to program your router manually to forward these ports to your server. If you are not sure, I would change your ISP!

Hvilken porter skal jeg skifte til, er det uansett hva jeg velger? Noen som vet?

Endret av duvethvem
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Hei!

Har akkurat satt opp WHS , funker glimrende.

Når det gjelder portene skal du ikke trenge åpne noen i Router om den er UPnP -sertifisert.

Når det gjelder din Bredbånsleverandør ville jeg krevd å få åpne de portene jeg vil ellers bytte leverandør. Forbanna Tull av dem å sette begrensninger på slikt , vitner om inkompetanse på området eller på vrangforestillinger om en Routers virkning.

Håper du får dette i havn. Der finns masser av Flotte Add.Ins til WHS.

Krev Skjerping fra din leverandør. :wall: :D

Les mer her om Remote

Technical Brief for Windows Home Server Remote Access

Endret av steinbk
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hei.

Ja jeg har prøvd å snakke fornuft med Agder breiband, men får bare NEIi derifra. Jeg bor på bygda, og dette er eneste bredbånd levrandør.

Dvs vi har telenor, men de tilbyr langt laver hastighet. Så her er eneste mulighet å få nye porter inn i WHS. har prøvd mange, men kommer fremdeles ikke i mål.

Jeg trenger forslag til porter som skal brukes isteden for 80 og 443.

Og ja routeren blir konfig helt som den skal på auto., grønt på alt, men det nytter jo ikke når portene er stengt fra internett uansett.

Får rødt kryss på web site access og remote access.

Så må nok få bytta ut portene 80 og 443, men til hva?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hei.

Ja jeg har prøvd å snakke fornuft med Agder breiband, men får bare NEIi derifra. Jeg bor på bygda, og dette er eneste bredbånd levrandør.

Dvs vi har telenor, men de tilbyr langt laver hastighet. Så her er eneste mulighet å få nye porter inn i WHS. har prøvd mange, men kommer fremdeles ikke i mål.

Jeg trenger forslag til porter som skal brukes isteden for 80 og 443.

Og ja routeren blir konfig helt som den skal på auto., grønt på alt, men det nytter jo ikke når portene er stengt fra internett uansett.

Får rødt kryss på web site access og remote access.

Så må nok få bytta ut portene 80 og 443, men til hva?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Så må nok få bytta ut portene 80 og 443, men til hva?

Jeg har ingen erfaring med WHS, men et sted må mann begynne å lete. :)

Google

Alternative Ports for WHS

Alternative for WHS port 80 - 443

http://wiki.wegotserved.co.uk/Setup_Altern...r_WHS_Web_Sites

Det hadde ikke vært nødvendig å starte en ny tråd om samme problem. <_<

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Skal i teorien ikke være så tungt å få dette til.

En mulighet er selvfølgelig en VPN tunnel inn til WHS, men dette er stortsett kun en løsning for å få forbindelse mellom WHS serveren og din bærbare maskin.

En annen mulighet er å sette opp routing lokalt hos deg.

Dersom routeren din har ca. de samme instillingene som min har, så skal du kunne fylle inn min.3 ting.

Trigger port - den porten som skal brukes for å lytte etter innkommende trafikk.

9999

WHS Server IP - Den interne IP addressen til serveren din.

10.138.0.1

WHS Server port - Den porten serveren skal motta trafikken fra triggerport på.

443

Når du da skal koble til utenfra så fyller du inn IP addresse og triggerport for å koble til.

*Ekstern IP* *9999*

Trafikken skal da routes til *10.138.0.1* *Port 443*

Obs - Tatt rett fra dumhode mitt - kom gjerne med rettelser dersom jeg er helt på jordet.

Obs2 - Når du velger triggerporter, prøv å velge porter som ikke er i bruk.

Port list

EDIT

Forøvrig høres svaret du fikk fra din leverandør noe kryptisk ut, og det høres ikke ut til at det er noen teknisk kunskap bak det, da en internett leverandør med alle porter opp til 1024 stengt i brannmur vil være noe bortkastet å betale noe som helst til da du faktisk er sperret ute fra vanlige POP3 tjenester, HTTP trafikk, SSH og mer til.

Endret av Horrorr
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hei igjen. Ja fikk løst problemet til slutt og hær er linken:

https://technocore.homeserver.com/wiki/inde...r_WHS_Web_Sites

Det meste løser seg om man tar tiden til hjelp, men enkelt var det ikke.

1. Assign the new ports

Access your WHS via RDP or Advanced Admin Console or, if you have them, monitor and keyboard. Open up the Control Panel and select Administrative Tools/ Internet Information Services (IIS) Manager. Expand servername in the left hand pane by clicking on the plus sign.. Then do the same for Web Sites. Right click on Default Websites to open up the properties box. Change the TCP port number from 80 to a new port number. I used 8080 because it was easy to remember but you can use whatever you want. Then change the SSL port number from 443 to a new port number. I used 4433. Click OK and close all of the windows.

2. Open the new ports in the firewall

Again open up the control panel but this time select Windows Firewall. Click on the Exceptions tab. Find the entries labeled HTTP, there will be two of them. Select one and click Edit. You want the one for port 80 so if you that was not your first selection try the next one. Change port 80 to what you chose for the TCP port in the previous section. Now do the same for HTTPS and change port 443 to your new SSL port number. Reboot your server for all of this to take effect.

3. Forward the ports from your router

You will need to access your router and forward the ports you have chosen to the IP address of your WHS. Since this procedure is different from router to router you will have to figure that part out on your own.

4. Configure your WHS Remote Access

Now comes the tricky part. Open up your Windows Home Server Console and select Settings/Remote Access. If web sites are not already on click Turn On. Under Router Configuration you will have errors. Click Details and it will most likely tell you that it cannot verify that your web site is available on your home server. Ignore this.

Under Domain Name I will assume that you already have a Windows Live Domain Name. If not, you will need to run the wizard to obtain one. If this is a second home server you will need a another (different) Windows Live ID to obtain the domain name for this second server. Once the wizard has completed and everything is configured click on Details. You should have green check marks next to "Verifying your internet connection to Windows Live", "Updating Windows Live Custome Domains" and "Verifying Windows Live Custom Domains records". You will probably have red Xs next to "Verifying your web site is accessable from the internet" and "Verifying remote access is accessable from the internet". Ignore these warnings. Close all windows on the WHS desktop.

Assign new ports

Open Firewall Ports

Web Sites

Domain Name

Done

Now go to another computer, open up a browser and attempt to access the WHS web site. You will need to use http://yourdomainname.com:8080 (or what ever your new TCP port number is) or use https://yourdomainname.com:4433 (or what ever your new SSL port number is). You can get to the public web site using HTTP but if you want to log in and access private web sites or shared folders you need to use HTTPS.

Additional Info

After going through this procedure you should be able to access the basic web sites and shared folders. But, you will not be able to remotely access other computers via the web sites unless you have also forwarded port 4125 to this WHS. If your ISP blocks this port then you are out of luck because best information is that this port cannot be changed. Also, if you have two WHS, you will need to forward 4125 to one or the other but not both which means that you can have remote access only through one Home Server.

Credits

This page was originally written by Etoa for We Got Served.

Retrieved from "https://technocore.homeserver.com/wiki/index.php/Setup_Alternate_Ports_for_your_WHS_Web_Sites"

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive