[LØST] Problemer med lyd på Doom3

12 innlegg i emnet

Skrevet

Heisann!

Jeg tester ut Doom3 på OpenSUSE 10.3.

Har en Dell Latitude D830 laptop med Nvidia 256MB skjermkort.

Har lastet ned demoen og installert og spillet starter uten problemer. Grafikken er ok og kjører hi-quality og 4xAA uten de store hakkingene.

Problemet er at lyden høres rar ut. Man kan høre snakkingen i bakgrunnen av masse datalyder. Lyden hørers us som om underverden i dataen prøver å kommunisere med meg på dataspråk :-)

Vel det eneste kravet for lyd var Alsa 1.0.6 og jeg har da nyere version på OpenSUSE10.3.

Så er det noen som har tips om hvordan få fikset lyden i Doom3?

Lydkontrolleren tror jeg er veldig standard AC'97 Intel 82801

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

har du sjekket winehq sine sider? Eventuelt kan du jo prøve og skifte til OSS istedet for ALSA.

EDIT: Mener faktisk og huske jeg har hatt samme problemet med et annet spill, der løsningen var å bytte til OSS. Uten å si det for sikkert.

Endret av serrghi
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Juster så systemet bruker riktig lydkort! :)

Endret av Veg@rd
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Well! Og hvordan gjør man det?

Juster så systemet bruker riktig lydkort! :)
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hos meg er AC'97 Intel 82801 og Realtek HD Audio samme kort (det ene er analog og det andre er digital lyd - tror jeg).

Prøv med digital lyd isteden ?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Ja men hvordan? Når jeg går inn Yast - Hardware - Lyd så får jeg bare opp en lydkontroller; 82801

På ID Software sine sider snakker de om å skifte over fra Alsa til OSS, men jeg vet ikke hvordan man gjør det i OpenSUSE.

Vet du?

Hos meg er AC'97 Intel 82801 og Realtek HD Audio samme kort (det ene er analog og det andre er digital lyd - tror jeg).

Prøv med digital lyd isteden ?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Du har sikkert vært inne på samme eller lignende sider ? Når alt annet feiler sjekker vi manualen.

Alsa and multichannel sound

Starting with build 1286, DOOM III on Linux now supports both Alsa and OSS sound backends, as well as multichannel sound.

If you are having trouble with Alsa, here are a few things you can try:

instead of the default device, try using plughw:0, and surround51 for multichannel. A lot of Alsa installations have a misconfigured default device. You do that by passing +set s_alsa_pcm <alsa_device_name> on the command line.

if you are trying to get multichannel sound, make sure stereo works already. You switch between stereo and multichannel with +set s_numberOfSpeakers 2 and +set s_numberOfSpeakers 6

on amd64 systems you may need to get the snd-ioctl32 module loaded in

Then, if Alsa doesn't work, try using the OSS emulation ( +set s_driver oss ) .. and after that, just use plain OSS ( the OSS/Free implementation, or even better the OSS/Linux one from OpenSound ). OSS is not an outdated and deprecated sound API. It turns out to be much easier to setup and operate than Alsa for a lot of people.

Jeg kjenner for dårlig til Linux til å kunne komme med bedre forslag til løsninger, Det med blå skrift er samme forslag som du har fått tidligere fra serrghi.

Endret av Morten58
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

gå i konsoll, skriv inn winecfg og trykk enter.

Da vil du få opp et konfigurasjonsvindu, her går du på lyd innstillninger (eller noe slikt) og der kan du hake av for OSS eller ALSA biblioteket, fjern ALSA haken og hak av for OSS istedet. Lagre og lukk. Da kan du prøve spillet og se om det fungerer.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Ehhhhh!

Doom3 kjøres ikke under Wine!

Den kjører Linux nativ!

Hvis jeg kjører Alsaconf og da virker alt som det fungerer.

Det er vist noe med Doom3.

Noen som har fått dette til å fungere?

RS

gå i konsoll, skriv inn winecfg og trykk enter.

Da vil du få opp et konfigurasjonsvindu, her går du på lyd innstillninger (eller noe slikt) og der kan du hake av for OSS eller ALSA biblioteket, fjern ALSA haken og hak av for OSS istedet. Lagre og lukk. Da kan du prøve spillet og se om det fungerer.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hei og takk for svaret!

Dette løste alle problemene, men jeg innser at problemet med lyden kun omfattet Demo-versionen.

Det å starte Doom2-demo med option om å bruke OSS, så var lyden helt iorden.

På full-version av Doom3, funket lyden uten problemer.

Jeg må si at faktisk ble imponert omder Doom3 på OpenSUSE da den kjørte med maks kvalitet uten problemer.

Det betyr at det er INGEN problemer med å lage gode spill på Linux. Det er kun manglende vilje blant spill-utviklere. Faktisk får jeg inntrykk av at Doom3 kjører BEDRE på Linux. Den starter på få sekunder og grafikken går meget kjapt på en simpel laptop. Vel det er jo en dedikert Nvidia Qadro NV140 256MB.

Jeg kjører orginalen på Windows XP. På en Acer Aspire AMD64 med ATI Radeone Mobile X1200 og det er en tragedie.

Må kjøre lavest på alt og enda hakker den.

Jeg mener at spill-utviklere må innse at Linux også kan kjøre gode og krevende spill!

Takk for hjelpen!

Ah daså, et raskt google søk så fant jeg løsningen:

http://www.neowin.net/forum/lofiversion/in...hp/t362357.html

Lykke til!

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet (endret)

Hei og takk for svaret!

Dette løste alle problemene, men jeg innser at problemet med lyden kun omfattet Demo-versionen.

Det å starte Doom2-demo med option om å bruke OSS, så var lyden helt iorden.

På full-version av Doom3, funket lyden uten problemer.

Jeg må si at faktisk ble imponert over Doom3 på OpenSUSE da den kjørte med maks kvalitet uten problemer.

Det betyr at det er INGEN problemer med å lage gode spill på Linux. Det er kun manglende vilje blant spill-utviklere. Faktisk får jeg inntrykk av at Doom3 kjører BEDRE på Linux. Den starter på få sekunder og grafikken går meget kjapt på en "simpel" laptop. Vel det er jo en dedikert Nvidia Qadro NV140 256MB.

Jeg kjører orginalen på Windows XP. På en Acer Aspire AMD64 med ATI Radeone Mobile X1200 og det er en tragedie.

Må kjøre lavest på alt og enda hakker den.

Jeg mener at spill-utviklere må innse at Linux også kan kjøre gode og krevende spill!

Takk for hjelpen!

Endret av Mons1
0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive