Får ikke meldt inn i domene?

33 innlegg i emnet

Skrevet

Hei

Sak:

DNS config er ok på DNS server.

Får ikke meldt inn (mail srv) w2k inn i domenet.

Får feilmelding med en gang, før den liksom begynner å browse, søke seg frem.

"The network location cannot be reached"

Hva jeg har gjort:

Får svar når jeg pinger fra eksternt, både på IP og navn.

Også hvis jeg pinger internt på srv.

Nettverks kortet vil jeg si at fungerer da, samt DNS er rett.

Dett er er ikke en ny innstalasjon, men en server som tilsynelatende ikke har vært en del av domenet i det hele tatt. de har hatt prob med tidligereikke har vært meldt in tidligere. Det har vært virus på serveren tidligere i sommer men det skal ha blitt fjernet av - ikke at det skal hindre å melde inn.

TCP/IP NetBIOS Helper Service kjører, men ikke som local systen account men som NT AUTHORITY\LocalService. Noen betydning?

Også prøvd å disable NetBIOS over TCP/IP uten hell

Noen tips? Står og venter. Dt er varmt her inne

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

tja. Er det installert brannmur software på serveren? hva sier event loggen?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Ja, men selv om jeg disabler dem går det ikke.

AVG og Trend (litt om hverandre) en liten periode til jeg har fått det opp.

Siste jeg har fra event loggen er før 12 idag - ingenting siden det:

The system failed to register network adapter with settings:

Adapter Name : {99C55954-1FDD-4E89-8516-FB38B3B06D52}

Host Name : delta

Adapter-specific Domain Suffix : gemsysas

DNS server list :

192.168.100.10

Sent update to server : None

IP Address(es) :

192.168.100.111

The cause of this DNS registration failure was because of DNS server failure. This may be due to a zone transfer that has locked the DNS server for the applicable zone that your computer needs to register itself with.

(The applicable zone should typically correspond to the Adapter-specific Domain Suffix that was indicated above.) You can manually retry registration of the network adapter and its settings by typing "ipconfig /registerdns" at the command prompt. If problems still persist, contact your network systems administrator to verify network conditions.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Fant denne: på Event ID 11151

"This issue may occur if you have implemented a single-label domain namespace. Microsoft does not recommend that you use Active Directory directory service domains with single-label DNS names"

Dette kom som default med SP4

Dette er et single-label domain. Ingen suffix, bare domenenavnet.

Hvordan kommer jeg rundt.

I loggen har vi Event ID 11151

Fant litt hos MS, 2 forandringer i registry hos DC, men hjelp ikke etter restart.

Noen forslag? Logger meg på om en times tid.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Det er nok DNS som er problemet her ja. Og du har prøvd ipconfig /registerdns ?

Men skulle det ha noe å si for innmelding i domenet? Hvordan kommer jeg rundt. Andre single-label servere er innmeldt tidligere uten problemer?

Nei skal vel ikke ha noe å si, men dette er sikkert den eneste mailserveren i domenet? (mail servere er jo også (ofte)registrert som en MX-record hos en ISP).

This may be due to a zone transfer that has locked the DNS server for the applicable zone that your computer needs to register itself with.

Virker som serveren prøver å registrere seg hos en alternativ DNS server eks. hos en ISP, og DNS serveren hos ISP naturligvis ikke tillater zone transfers.

hvis du skriver ipconfig /all hvor mange dns-servere dukker opp da?

Kan du sjekke din DNS server, under forward lookup zone, "domenenavn" om den er registrert som en MX - record der? og med det samme kan du jo høyreklikke på "domenenavn" og sjekke instillingene der på bl.a. zone transfers og dynamic dns.

Du kan jo prøve å skrive inn Event ID fra event loggen her:

www.eventid.net

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Takk for konstruktivt svar. Det var vel innlegget ditt fra juni om nesten det samme?

Har ikke prøvd /registerdns. Skal se imorgen så følg med er du snill.. :)

Men som du ser i tråden så får jeg pinget serveren både på navn og IP. Skulle være et godt svar på at DNS fungerer.

Skal også kjøre ipconfig /all og se under forward lookup zone etter MX recorden.

Men har du lest tråden? knowledge base

"Starting with Windows 2000 SP4, the default setting for dynamically registering DNS records changed. In Windows 2000 SP4, Windows does not dynamically register DNS records in a single-label domain".

Tror du ikke at dette påvirker mitt forsøk på melde in w2k serveren?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

stemmer primary dns suffixet på mailserver overns med primary dns suffix på domenet ditt ?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Kan det være at maskinnavnet er registrert på DNS server fra før med en annen IP eller no? Skriver du riktig domenenavn når du skal melde inn serveren?

Ettersom du får pinget både på navn og ip så spørs det vel om problemet ligger på DNS.

Bare tenker litt høyt her :P

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Den artikkelen du sikter til exchange har jeg prøvd tidligere - funket dessverre ikke. Men som tråden viser så er det problematikk med SP4 på w2k srv som forandret deafult, slik at single-label domene navn, uten suffix'et, er vrien å få inn i domenet.

DNS er står ikke noen andre steder enn på en IP.

Domene navnet er enkelt å skive - det er bare single-label. :)

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hva om du installerer Windows 2000 support tools og kjører kommandoer som : netdom og netdiag?

http://support.microsoft.com/default.aspx?...Ben-us%3B329721

Jeg ville også kjørt en nslookup test for å utelukket dns problemer:

http://www.microsoft.com/resources/documen...s.mspx?mfr=true

(trykk på linken: to verify the dns .....)

Har det ikke kommet en oppdatering til SP4? service pack 4 versjon 2 el. (eller kanskje du skal oppgradere serveren til W2003, men det er vel litt drøyt).

En annen ide er kanskje å kjøre sysprep for å generere en ny SID for serveren. (I og med at det har vært virus på serveren....)

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

God morgen Halås.

Da skal jeg se på forslagene dine så kommer jeg tilbake med resultater :)

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

En annen ide er kanskje å kjøre sysprep for å generere en ny SID for serveren. (I og med at det har vært virus på serveren....)

SID-problematikk skal i hvert fall ikke kategorisk utelukkes her.

Sysprep er jo en mulighet, men liker selv veldig godt en liten utility fra Sysinternals: http://www.sysinternals.com/utilities/newsid.html

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Litt ukjent med sysprep. Noen gode veivisere?

Har lastet ned sysprep tools og inst. Leser litt

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Litt ukjent med sysprep. Noen gode veivisere?

Har lastet ned sysprep tools og inst. Leser litt

Hvis du bruker NewSid som jeg linket til over behøver du ikke sysprep. NewSid er veldig enkel i bruk :)

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Jo, takk. newSID var enkel i bruk men løste dessverre ikke noe det heller.

Ok - oppsummerer litt nå.

Win2k server med alle oppdateringer.

Får ikke meildt inn server i domenet. Det er dessverre et single-label domene.

Ved passord begynner den ikke engang å søke.

Skriver ingenting i loggen ved feilmeldingen som kommer opp.

"The network location cannot be reached."

Hva jeg har gjort:

Pinget på IP og DNS og får svar fra DNS server - altså DNS ok?

Så fant jeg denne. Event ID 11151 Løste ikke saken.

Har sørget for at TCP/IP NetBIOS Helper Service kjører.

Har nå kjørt newsid. Ny SID opprettet men det fungerte ikke.

Brannmurer og antiviruser er disablet under forsøkene.

Ikke prøvd tipsene om:Windows 2000 support tools og kjører kommandoer som : netdom og netdiag. Litt usikker der.

Har kjørt ipconfig /registerdns så får vi se på loggen.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

MCSE security

- - - -forward lookup zone, "domenenavn" om den er registrert som en MX - record der? og med det samme kan du jo høyreklikke på "domene navn" og sjekke instillingene der på bl.a. zone transfers og dynamic dns - - -

Hva skal zone transfer så på (litt ukjent med innstillingene)

Hos meg er den ikke på.

Men jeg har MX records og Dynamic update står på "secure only".

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Når jeg kjører nslookup får jeg:

"Can't find server name for adress 192.168.100.10 (DNS server's)

Non-existent domain. Default server: Unknown

Adress: 192.168" og resten..

Snodig for den ser jo IP adressen til dns serveren?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hvor blir det av loggen som ipconfig /registerdns skriver etter 15 min?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

For skjekke at forward lookup & reverse lookup i dns funker

------------------------------------------------------------------------

Hvis du hadde feks en server som het: server01 med ip 192.168.8.10

----------------

Skriv i cmd:

nslookup 192.168.8.10

nslookup server01

---------

hvis du da for opp infon skal dns oppslagene funke begge veier.

-----------

sett dynamic dns til nonsecure & secure

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Når jeg kjører nslookup får jeg:

"Can't find server name for adress 192.168.100.10 (DNS server's)

Non-existent domain. Default server: Unknown

Adress: 192.168" og resten..

Snodig for den ser jo IP adressen til dns serveren?

ok.

Kan se ut som om du ikke har satt opp reverse lookup zone?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

a-ha

Får ikke opp noe info om dns server.

"Can't find server name...."

Men på den andre siden så er 4 andre server meldt inn?

Fremgangs måte?

Du var raskere til å svare :)

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Skal vi se

Jeg får ikke svar hverken på nslookup DNS IP eller navn.

Men jeg får pinget DNS IP og navn?

Men her er det 2 kataloger i dns treet

Forward lookup zone og

Reverse lookup zone.

Forward = Running. Men hvorfor får jeg ikke svar på nslookup IP da?

Reverse er tom. Hvordan skal den se ut? Får ikke samme struktur som Farward?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

hmm vrient dette ja, men jeg tror fortsatt at dette er et dns problem..

Hva skal zone transfer så på (litt ukjent med innstillingene)

Hos meg er den ikke på.

Men jeg har MX records og Dynamic update står på "secure only".

Zone transfers skal som regel ikke stå på. (med mindre du har flere dns servere).

kan du høyreklikke på MX recorden til mail serveren og se på FQDN, sjekk også fanen for sikkerhet.

Du kan jo også prøve å sette Dynamic update til Nonsecure.

(hvis du sletter MX recorden fra dns og deretter prøver å melde serveren inn i Domenet. (da må du kjøre ipconfig /flushdns og ipconfig /registerdns før du melder serveren inn i domenet).

Event. kan du jo prøve tipset til M.O.H om å sette opp en reverse lookup zone.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Prøvde forslagene ved slette MX recorden fra dns og deretter prøver å melde serveren inn i Domenet. (da må du kjøre ipconfig /flushdns og ipconfig /registerdns før du melder serveren inn i domenet).

Gikk ikke, men jeg har lært mye da :)

Har prøvd meg frem med å add reverse lookup ved å høyre klikke på mappen reverse lookup (som er tom forøvrig). Men usikker på valgene.

Som sagt Forward kjører. Burde jeg ikke da fått svar på nslookup og ip adressen?

Noe annet - spiller det noen rolle om zonene kjører? Har jo bare et domene, ikke inndelt i noen zoner?

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive