[LØST] Får ikke connecta ftp server fra utsiden

10 innlegg i emnet

Skrevet

Jeg har satt opp bulletproof ftp server på min w2k3 server. Satt opp ftp brukere osv. Jeg får connecta ftp servern fra lanet. Men når jeg skal prøve å connecte servern på utsiden så får jeg opp bildet der du skal taste bruker navn og passord. Jeg har et speedtouch routermodem fra nextgentel(den som har innebygd switch) Jeg har satt opp sånn at port21 router til servern der ftp ligger. Men når jeg skal taste brukern og pass for å logge inn så får jeg bare at jeg har feil pass. Har ikke skrivd passet feil. Trust me. Hva kan være galt`? Og når jeg kikker på ftp om hvem som prøver å logge seg på, så står det ikke noe om at den brukern jeg prøver å logge på med fra nettet. Prøver å logge seg inn på ftp servern..

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Du må sette regelen som åpner for port 21 over den regelen som stenger for alle porter under 1025 i routeren fra NGT.

Hadde samme problem og det ble løst ved å flytte ftp regel over den regelen som stenger for all trafikk under porter 1025.

Du må gå inn i et annet skjermbilde enn det du bruker når du oppretter regelen for å flytte regelen.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Takk, men kunne du forklart åssen du går fram. Finner ikke helt hvor den regelen op 1025står

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Har du vært inne på Speedtouchen via telnet?

Hvis du har vært inne i den så må du gå inn i Display/Change filter Set og Velge Move Input Filter.

Har du ikke vært inne på den før, så må du søke på nettet.

Jeg har en Netopia router slik at jeg ikke kan gi deg riktig svar, ettersom jeg regner med at det er to forskjellige oppsett på routerne.

Edit: det er ikke port 1025 men port 1023 filteret for ftp må settes over.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hvis vi antar dette er en Thomson ruter ifra NGT så er oppsett for FTP på ruterene

516/546/585 dette :

FTP server:

Åpne din nettleser.

I adressefeltet skriver du http://10.0.0.1 og trykker Enter.

Du vil da komme inn på din Thomson ruter.

Her inne velger du Hjemmenettverk fra menyen på venstre side.

Videre velger du hvilken nettverks enhet din NAT oppføring skal gå mot.

Etter dette, velger du Tilordne et spill eller en applikasjon til en lokal nettenhet

Du vil da få opp en ny side, med informasjon om eksisterende NAT oppføringer, samt mulighet til å legge inn nye.

Her velger du først applikasjonstype i rullegardinsmenyen. Om du ønsker oppføring for FTP server, velger du dette i menyen.

I rullegardinsmenyen til høyre for denne velger du igjen nettverksenhet oppføringen skal gå mot.

Du kan nå trykke legg til, og se at oppføringen blir lagt inn i menyen.

Når dette er gjort, kan du lukke din nettleser.

Du går så på start - kjør. I dialogboksen skriver du telnet 10.0.0.1, og trykker ok.

Brukernavn/passord er Administrator/(passord blankt)

Her inne skal du skrive følgende kommandoer:

service system modify - Trykk Enter

ftp- Trykk Enter

disabled- Trykk Enter

21- Trykk Enter

saveall- Trykk Enter

Du kan nå lukke vinduet.

Tilgang for FTP server skal da være aktivert på din router.

mvh

Pingni

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hei takk for hjelpen. Men det som skjer i Telnet er at jeg får opp denne beskjed på slutten

name = FTP

[state] = disabled

[port] = 21

[log] = enabled

:service system modify name=FTP state=disabled port=ftp log=enabled

Port change conflict with existing service.

Og jeg har kikket på speedtouchen i nettlesern, men finner ingen den kan gå i konflikt med...

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hei

Da er det en konflikt med en eksisterende oppføring

Åpne Telnet

skriv inn :

nat maplist

Du vil da få opp en kolonne med indexnummer, her er all info om vilke porter som er åpne.

Se igjennom denne og finn oppføringen som du vil slette.

Du skriver: Eksempel-" nat mapdelete intf=B_1 index=1" hvor index er nummeret på oppføringen du vil slette.

Det er ikke sikkert at din heter B_1 dette er forskjellig ifra NGT Din kan f.eks. hete A_2 Og husk "saveall"

Her er en link til en web side hvor du kan sjekke online vilke porter som er åpne

http://tester.datasec.no/manuell_portsjekk

Mvh

Pingni

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Jeg hjalp en kar med å endre filtersettet for en stund tilbake.

Det lureste vi gjorde var å fjerne hele filtersettet som Nextgentel hadde lagt inn. Det gjøres ved å gå inn på Nextgentel sin side for endring av routermodem-oppsett her velger du løsningen "uten filterset" så vidt jeg husker. Det skal nå være mulig å legge inn dine egne regler som nevnt over. Den enkleste måten var riktignok via TelNet.

Fant også et par andre linker som kan hjelpe:

-Her

-Her

-Her

Håper dette hjelper.

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Vil si at problem har løst seg, men iallefall takk for hjelpen jeg har fått=)

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Skrevet

Hei

Da er det en konflikt med en eksisterende oppføring

Åpne Telnet

skriv inn :

nat maplist

Du vil da få opp en kolonne med indexnummer, her er all info om vilke porter som er åpne.

Se igjennom denne og finn oppføringen som du vil slette.

Du skriver: Eksempel-" nat mapdelete intf=B_1 index=1" hvor index er nummeret på oppføringen du vil slette.

Det er ikke sikkert at din heter B_1 dette er forskjellig ifra NGT Din kan f.eks. hete A_2 Og husk "saveall"

Her er en link til en web side hvor du kan sjekke online vilke porter som er åpne

http://tester.datasec.no/manuell_portsjekk

 

Mvh

Pingni

Jeg henger meg på her fordi jeg har identisk utstyr (speedtouch 546i), leverandør (ngt) og problem som trådstarter. Jeg har ikke fått løst dette, men jeg klarer ikke helt å se av nat maplist hva som foregår. Flere porter går til 127.0.0.1, men dette er såvidt jeg vet ikke et subnett på mitt nettverk.

Pc'en jeg vil kjøre ftp port 22 på heter 10.0.0.4 og speedtouchen er 10.0.0.1.

Feilmeldingen:

.{Administrator}=>:service system modify name=FTP state=disabled port=22 log=dis

abled

Port change conflict with existing service.

.{Administrator}=>

Håper kanskje noen ser problemet her.

Dette er de første linjene i nat maplist (har anonymisert wan-ip'en):

_{Administrator}=>nat maplist:

Idx Type Interface      Outside Address                Inside Address

      Use

  1 NAT  TypeA_1        [224-239].*.*.*                [224-239].*.*.*

      0

  1 NAT  TypeA_2        [224-239].*.*.*                [224-239].*.*.*

      0

  1 NAT  TypeA_3        [224-239].*.*.*                [224-239].*.*.*

      0

  1 NAT  TypeB_1        80.202.xxx.xx                  127.0.0.1

      0

  2 NAPT TypeB_1        80.202.xxx.xx:80              10.0.0.4:80

      0

  3 NAPT TypeB_1        80.202.xxx.xx:1214            10.0.0.4:1214

      0

  4 NAPT TypeB_1        80.202.xxx.xx:1863            10.0.0.4:1863

      0

  5 NAPT TypeB_1        80.202.xxx.xx:[6891-6900]      10.0.0.4:[6891-6900]

      0

  6 NAPT TypeB_1        80.202.xxx.xx:161              127.0.0.1:161

      0

  7 NAPT TypeB_1        80.202.xxx.xx:1900            127.0.0.1:1900

0

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå

  • Hvem er aktive   0 medlemmer

    Ingen innloggede medlemmer aktive