Gå til innhold


Bilde

Problemer med Charset i script


  • Vennligst logg inn for å svare.
3 svar til dette emnet

#1 Credotrynet

Credotrynet

    Nyansatt

  • Pip
  • 2 Innlegg:
  • System: Mac

Skrevet 28 April 2011 - 20:48

Hei,

Jobber med installasjon og oppsett av et system kalt WorkorderTS
www.workorderts.com/

Problemet er at når jeg skal skrive en beskrivelse på en sak, og bruker tegnene Æ, Ø eller Å blir tegnene helt merkelige etter at jeg har lagret saken...

Sjekket i kildekoden, og den bruker Latin1, det samme gjør MySQL-databasen.

Noen som har en anelse om hva det kan være?
Setter stor pris på all hjelp! :)
  • 0

#2 Martin Aleksander

Martin Aleksander

    Daglig leder

  • 4408 Innlegg:
  • System: Windows 7

Skrevet 28 April 2011 - 20:55

UTF-8 eller iso-8859-1 er vel korrekt charset å bruke.
  • 0

#3 Credotrynet

Credotrynet

    Nyansatt

  • Trådstarter
  • Pip
  • 2 Innlegg:
  • System: Mac

Skrevet 28 April 2011 - 21:38

Det er iso-8859-1 den bruker. Også fant jeg ut at den ikke støttet UTF-8..
Skjønner virkelig ikke hvorfor æ, ø og å blir feil.
  • 0

#4 feskehau

feskehau

    Nyansatt

  • Pip
  • 31 Innlegg:

Skrevet 24 March 2012 - 01:08

For det første må charset du lagrer filen i samsvare med det som du oppgir i http headeren som blir sendt til brukeren, og så må det være samme i html headeren. henter du info fra en database må php vite hvilken charset du har i databasen også. Bruk UTF-8

Dette innlegget er endret av feskehau: 24 March 2012 - 01:09

  • 0




0 bruker(e) leser dette emnet

0 brukere, 0 gjester, 0 anonyme brukere